Friday, 17 September 2010

Image dump - Ribbon actions are disabled

Problem: Adding a new domain account user to the "Farm administrators" group. The new account mydomain\mstest1 cannot use the "New", "Extend" or "Delete" buttons on the ribbon within "Web Application Management".
Rolling over the buttons on the ribbon display the following information: "This control is currently disabled." "You might not have the right permission level to use this, you might need ...".
Additionaly you will also notice the "Manage Service Applications" will not allow you to create or delete new Service Applications.
New user in the Farm administrators group
Hypothesis: The new farm administrator does not have the appropriate permissions on the configuration database.

Resolution: Give the new administrator db_owner rights and the ribbon action options are available.

Further Info:
By making a content database read-only as shown below all Site Collections become read-only, ribbon actions are disabled.  Not coentent can be added to the Site Collection.
Make the content db read-only

Resulting Site Collection (Can't use most ribon options)



NLB
NLB 2

5 comments:

westerdaled said...

Hi

I am getting the exact same issue with my farm admin account I used to install SP 2010 Foundation on my dev laptop.
1)I have checked that I have the role as dbo in WSS_Content - Have not specified owned schemas
2)in the Security folder for the SP2010 SharePoint db server. I have added my account to securityadmin and dbcreator.

Yet still I am unable to create a web app.... at least I was able to do this in WSS!

PaulB said...

Hi Westerdaled,

The account/farm admin needs dbo rights (Owner rights) on the "configuration database" in SharePoint, not "content database's".

Look at the farm admin account you are using has database owner rights on the SharEPoint_Config db, the actions explaiened above will become available when the user has the correct SQL Server access rights.

kind regards,
paul

Anonymous said...

If you are on your virtual machine remote desktop you must run IExplorer as administrator with context menu on IE Icon

Unknown said...

Thank you Anonymous - running IE as Administrator is the fix I needed.

Unknown said...

Thank you Anonymous - running IE as Administrator is the fix I needed.

Post a Comment