Tuesday, 10 August 2010

Reusable content in SP2010 issue

Problem:
1.> Reusable content is added to an html field control as shown below

2.> Under the "Reusable Content" inserted into the page inside the same field contrl, add any OOTB web part.
3.> When you save or publish the page, the html gets mixed around and displays incorectly.

Hypothesis: I have to think this is a bug as each item can be added individually.
Possible Resolution:
  • Use different page layouts with more field controls or
  • programatically retrieve the reusable content and display it or
  • Use a dataview WP with custom xslt to display the reusable content.
Tip: Reusable content is not available inside web parts. So like in MOSS, you cannot insert reusable content inside the OOTB content editor web part. Reusable content is only available in field controls.
Tip: Reusable content is similar to what it was in MOSS, it is available if the SharePoint Server Publishing feature is activated in both the "Site Collection Features" & "Manage Site Features".

Additional infoSerge Luca confirmed this issue.

5 comments:

Eugene Rosenfeld [2-time MOSS MVP] said...

We've been seeing this same issue on both MOSS 2007 and SharePoint Server 2010. It's driving me nuts. Please post any resolution to the issue. Thanks.

Paul Beck said...

Hi Eugene, This is a SP2010 bug. Pretty painful and the only resolution which, is not ideal is to use the same approach as we used in MOSS in that web parts can't be intermingled with reusable content.

Alan Coulter said...

If I have a long list of reusable items, as you move your mouse down the list, sometimes SharePoint inserts a reusable content item that you have not selected. Other times I have seen as you scroll down the list, the reusable content selection disappears and it looks like you are no longer in Edit mode. You have to click Save and Close, then go back into edit mode.

Christopher Renaud said...

FYI - You need to install the June 2011 CU and it will resolve the issue you're reporting. Keep in mind that you'll need to add the reusable content to the effected pages again.

Alan Coulter said...

I have upgraded to the Feb 2012 CU and the issue still exists. Also, the flag to show Reusable Content in the dropdown is being ignored (all of my items are set to not display in the drop down - I was hoping tha the 'More reusable content...' link would behave better).

Post a Comment